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Abstract: Since the development of distribution and transmission networks, power system engineers have sought to detect fault 

locations and provide real-time monitoring. By enabling the disconnecting of faulty lines prior to any serious equipment damage, 

quick fault detection can assist safeguard the equipment. Utility workers can eliminate recurring issues with the aid of the precise 

problem location.  

 

Defects and identify the locations where they frequently occur, therefore minimizing the frequency of faults and power 

interruptions. In order to sufficiently and precisely identify and find the precise area where the problem had occurred, an internet 

of things-based fault detection and location system was employed in this paper. This will guarantee that the technical team can 

address these errors more quickly. The sensor and microcontroller detect when a defect occurs in a cable line and notify the user 

of it. 

 

Index Terms - KV fault detection; fault detection Using IoT. 

I. INTRODUCTION 

 

The growth of electric power networks has been tremendous over the last fifty years. As a result, both the number of active lines 

and their overall length have significantly increased. One common way to move power from one place to another is by using 

overhead transmission wires to transfer electricity. In this vital service, failure is a serious problem. To recover from the failure, the 

fault's location needs to be determined. If the fault's position can be reasonably anticipated or is known, the restoration process can 

go more quickly. Finding and identifying power line faults is essential to the power system's smooth operation. Electrical power 

systems frequently experience power line faults, which render the power system unreliable. Rapid and accurate fault location is 

critical to shortening outage times, increasing system reliability, and speeding up system restoration. While problem identification 

requires human labor, technologically aided methods can reduce costs and save time. 

 

A. Research Statement 

In addition to fault frequency being higher on the distribution side, losses in the distribution system are substantially larger than 

those in the transmission side. The majority of losses in distribution systems are brought on by error and theft. The single phase to 

ground fault in power lines is the main topic of this research. Accurate and timely fault detection becomes critical when a single 

phase to ground fault occurs. It gets harder for the power company to find the problem and fix it as soon as feasible. Protection 

systems are made to locate faults and isolate the affected area alone, preventing damage to the power system's entire equipment. 

Trial and error method is the current solution for fault detection.. It divides the transmission line into two sections and checks the 

fault up to that portion, feeding the single end at a time. These procedures continue until the fault location is identified. If they 

find anything, it's safe to move forward; if not, it will require more time and labor. The goal of this research is to provide a 

straightforward method for identifying faults and pinpointing their precise locations, which will ultimately result in the system 

operating at peak efficiency and increase the distribution network's dependability. IoT-Based Method The goal is to locate the 

distribution line fault and notify the server of its position. Sensors are utilized to accurately identify distribution line faults. The 

transmission line's power characteristics are detected by the sensors. To provide a reliable, efficient, and impedance-based 

automated fault finding and detection system for overhead electricity transmission lines [2]. to shorten the time it takes to fix a 

problem and protect pricey transformers from theft or damage, which typically happens during prolonged power outages. The 

scope of this research is restricted to the design of an effective system that can locate and identify faults in overhead lines, both 

line to line and line to ground. This system should be able to provide real-time monitoring and automatically alert the control 
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room or online at the precise location of the cable line where a fault has occurred [1]. 
B. Research Methodology 

 

     Using an impedance-based approach, the distance between the problem and the main distribution bus is assessed. This method 

requires measurements of the voltage and current at one or both ends of the line. The fault position is estimated using the method 

using mathematical calculations. Proposed a method that made use of the basic frequency voltages and currents recorded at a line 

terminal both prior to and during the fault [3]. In order to explain the fault location approach, a single-phase-to-ground fault was 

taken into consideration. A method based on measurements from Intelligent Electronic Devices (IEDs) with an oscillography 

capability built in was offered. This is installed only on a database that houses details about the electrical parameters and network 

topology at the substation level. Especially on 11kV networks that make use of IoT devices. 

 

 

II. PROPOSED BLOCK DIAGRAM 
 

Fig.1 Proposed system 

 
A. Tmega328p Microcontroller 

 
One of Atmel's most well-known microcontroller chips is the Atmega328. This 8-bit microcontroller contains 2K of internal 

SRAM, 1K of EEPROM, and 32K of flash memory. There are 28 pins on the Atmega328. It features 14 digital I/O pins, 6 of 

which are analog input pins and 6 of which are PWM output pins. 

 

B. Current Transformers (Sensors) 

One kind of "instrument transformer" is the Current Transformer (C.T.), which is made to measure current in its main winding 

and produces an alternating current in its secondary winding that is proportionate to that current. Current transformers offer a 

practical means of securely monitoring the actual electrical current while reducing high voltage currents to a considerably lower 

value. Use a typical ammeter while flowing in an AC transmission line. A fundamental current transformer operates on a 

somewhat different principle than an ordinary voltage transformer [4]. When expressing the primary and secondary currents as a 

ratio, like 100/5, most current transformers have a typical secondary rating of 5 amps. This indicates that the primary current is 20 

times higher than the secondary current, meaning that the secondary winding will only flow 5 amps for every 100 amps running in 

the primary conductor. For every 500 amps in the primary conductor, a current transformer with a ratio of, say, 500/5 will 

generate 5 amps in the secondary, which is 100 times more. The secondary current can be made much smaller than the current in 

the primary circuit being measured by increasing the number of secondary windings, Ns, because the secondary current decreases 

proportionately with Ns. Stated otherwise, there exists an inverse relationship between the primary and secondary windings' 

current and turn count. The amp-turn equation must be satisfied by a current transformer, just like it must by any other 

transformer. From our lesson on double wound voltage transformers, we know that this turns ratio equals: 
𝑁𝑃 

𝑠𝑒𝑐𝑜𝑛𝑑𝑎𝑟𝑦 𝑐𝑢𝑟𝑟𝑒𝑛𝑡, 𝐼𝑆 = 𝐼𝑃 ( )    (2.1) 
𝑆 

 

C. ESP8266 Module 

The turns ratio is determined by the current ratio, and since the secondary can have several hundred turns while the primary 

typically has one or two, the ratio between the two can be rather big. Assume, for instance, that the primary winding's current 

rating is 100A. The standard rating for the secondary winding is 5A. Then, there is a 20:1 ratio, or 100A to 5A, between the 

primary and secondary currents. Stated differently, the primary current exceeds the secondary current by a factor of 20. However, 

altering the primary turns through the CT's window—one primary turn is equivalent to one pass—allows for relatively 

considerable adjustments in a current transformer turns ratio. Several passes through the window alter the electrical ratio [5]. 

 

Shanghai, China-based fabless semiconductor company Espress if Systems produces the ESP8266 series, or family, of Wi-Fi chips. 
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The ESP8266EX, also called ESP8266, is a system-on-a-chip (SoC) that combines filters, power management modules, standard 

digital peripheral interfaces, antenna switches, radio frequency (RF), power amplifier, low noise receive amplifier, and a 32-bit T 

microprocessor into a compact package. It has capabilities up to 2.4 GHz. A series of wireless MODEM devices called Esp8266 

MODEM is intended for computer-cloud network connection. It features an 80 KB user data RAM, 32 KB instruction RAM, and 

64 KB boot ROM. For identification, they also have an IMEI (International Mobile Equipment Identity) number, which is 

comparable to that of a cell phone. An esp8266 is capable of the following tasks: Using a cloud, sends, receive, and delete SMS 

texts.Communication Protocol 

Message Queue Telemetry Transport is referred to as MQTT. It is a protocol for sending messages between two locations, as its 

name would imply. This protocol can transport data over long-distance, occasionally sporadic networks and is so lightweight that 

it can be handled by some of the smallest measuring and monitoring devices [6]. By combining well-established software 

processing methods with the quickly growing physical world of sensors, actuators, phones, and tablets, MQTT aims to address 

these difficulties. Additionally, because bandwidth and battery life are limited in the rapidly developing M2M or Internet of 

Things (IoT) world of linked devices, these factors make this protocol perfect. Two main components make up the MQTT high-

level architecture: a broker and a client. The essential component of the architecture is a broker, which can function as a publisher 

as well as a subscriber. 

III. MATLAB SIMULATION 

 

Fig. 2. 11KV  Line Simulation in MATLAB 

 
 

Fig.3. 11KV Voltage Waveform in MATLAB 
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Fig.4 11KV Current Before Fault 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig.5 11KV Line Current Waveform After Fault 

Fig. 6. 11KV Line Fault Current Waveform in 1-Phase 

If the KVA value is taken as standard data, then the line-to-ground current fault can be calculated simply: 

11KV LINE CURRENT: 

KW = KVA*PF 

POWER [KW]= 2900*0.9 

POWER = 2610 KW 

POWER [KW]= root(3)*KV*I*PF 

Root (3) = 1.732 
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2610= 1.732*11*I*0.9 

2610/1.732*11*0.9 = I 

A. Writing Sketches 

Sketches are programs created with the Arduino Software (IDE). These drawings are saved as files with the.ino extension and are 

created using a text editor. Complete error warnings and other text output from the Arduino Software (IDE) are displayed in the 

console. The configured board and serial port are shown in the window's lower right corner. The two main sections of the sketches 

are the void setup section, which describes the entire circuit component setup and the directives that components in the second 

part, the void loop, use to make all set components active continuously during program execution. For example, the 11 kV fault 

detector continuously displays results on an interfaced LCD, indicating that it is sensing current through a current sensor. Thus, 

we may state that LCD will print any command given to it by GSM AT. When programming starts, other libraries can be added at 

the top [7]. 

B. Libraries 

Libraries offer additional features for use with sketching, such as data manipulation and hardware operation. Choose a library 

from the Sketch >Import Library menu in order to utilize it in a sketch. This will compile the library with your drawing and add 

one or more #include statements to the top of the sketch. Since libraries are posted along with your sketch to the board. 

C. Uploading 

Make sure you have selected the appropriate elements from the Tools > Boar and Tools > Port menus before uploading 

your sketch. The names of ports differ depending on the operating system. After choosing the appropriate serial port 

and board, click the toolbar's upload button or choose the Upload option from the Sketch menu. The upload will start 

immediately when the current Arduino boards reset [8]. 

While the sketch is being uploaded, the RX and TX LEDs blink. When the upload is finished, the Arduino Software 

(IDE) will either show a message or an error [9]. 

IV. Conclusion 

In conclusion, by automatically giving precise fault location information, especially in the 11 kV line system, the suggested method 

will reduce the amount of time needed to find a defect. The current both before and after the fault is displayed by the 11 kV line 

simulation. 
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